Z-Notes

主にZBrush、3dsMax、3d-Coatなどの3DCGアプリに関する覚え書き。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Windows7 操作性の改善

SSDへのWindows7のクリーンインストールが終わったので設定等を前の環境に近づけていきます。

とりあえず行った主な設定の変更や不具合の解決法を覚書としてまとめてみました。


・PDFのサムネイル表示

64bit版Windowsではこれが表示されないため非常に不便になっています。

これはWindows10でも改善されていないようです。

これを表示させる方法は次のようなサイトが参考になるでしょう。

http://www.itmedia.co.jp/bizid/articles/1304/16/news038.html

http://trendy.nikkeibp.co.jp/article/pickup/20140805/1059404/?P=3


その他にPDFを開くソフトを「Adobe Reader(Acrobat)」以外のサムネイル表示できるものにするのも一つの方法ですね。



・エクスプローラーのツールバーにボタンを追加する

Windows7になってエクスプローラーのツールバーには「削除」ボタンがなくて非常に不便なのでこれを表示させる方法です。

これは下のサイトが詳しいでしょう。

http://news.mynavi.jp/column/windows/114/


使用するフォルダータイプごとに設定が必要でかなり面倒だしレジストリをいじるのでお手軽では無いです。

また安全のため変更前にレジストリをバックアップしておきます。

とりあえず追加するのは「削除」ボタンくらいにしてます、あんまりいろいろ表示させても使いにくそうなので。

それにこの方法でレジストリを編集しても表示されないボタンもあるようで、なんかよくわかりませんw。

上のリンクの後半に説明のある「アクセス許可」を取る手順の説明はわかりやすいですね。

こういうのは自力では絶対わかりませんw。


これもWindows10にアップグレードすればリボンインターフェースが使えてエクスプローラーも便利そうではありますが。



・Aeroのスナップ起動を停止

ウィンドウをドラッグしてると勝手にリサイズされてしまう機能を無効にします。

下のサイトを参考にしました。

http://www.atmarkit.co.jp/fwin2k/win2ktips/1249win7snap/win7snap.html



・「Tablet PC Input Service」の停止

特定のソフトでペンタブを使うときに挙動がおかしくなったりした時このサービスを停止すると改善する場合がある。

やり方

恒久的に停止にしたい場合は

スタートボタンを押し検索欄に「msconfig」と入力して「enter」キーを押す(「Windowsキー+R」で「ファイル名を指定して実行」からでも可能)。

開いた「システム構成」ウィンドウの「サービス」タブで「Tablet PC Input Service」を見つけチェックを外す。

「OK」を押して再起動。


一時的に停止にしたい場合は

タスクマネージャーを起動し「サービス」タブで「TabletInputService」を右クリックして「サービスの停止」を選択するだけ。

この場合再起動するとサービスは再開されます。

他に「コンピューターの管理」で停止する方法などいくつかやり方があるようです。



・Windows起動時にキーボードやマウスが一時的に反応しない

この現象はUSBドライバーに原因があることがわかりドライバーのインストールで解決しました。


・オンボードのRealtek HD Audioで音が途切れる問題

ブラウザやメディアプレイヤーなど動画などを再生していると音声が途中何度か1、2秒ほど途切れてしまう。

これはネットで検索すると結構あるみたいでしかも解決方法も様々。

ネットの情報などを参考にここで行ったものを並べてみると

・Asusからマザボ用のRealtekサウンドドライバーで異なるバージョンを試す


・Realtekのサイトから直接ダウンロードしたドライバーを使う


・Realtekオーディオマネージャーの設定変更


オプションの「通知領域にアイコンを表示」をオフ

「デバイスを挿した時のポップアップダイアログを有効にします」をオフ

その他設定を変更して試す

オーディオマネージャーの停止


・Windowsのサウンド設定を変更

「音の明瞭化」で「すべての音の明瞭化設定を無効にする」をオン


・USB接続のデバイスなどを外す


いろいろやったが結局解決できず、最後の手段でRealtekのドライバーのアンインストールで解決しました。

繋げているのは普通のステレオスピーカーなのでWindows標準のドライバーだけでも特に音質が悪くなるということも無いようです。

オンボードサウンド機能を十分に利用できないかも知れないけど、音が途切れるのは気になりだすと我慢できないので。

多分スピーカー端子の接続がすこし不安定なのを敏感に検出しすぎているのが原因かもしれません。


ただRealtekのドライバーをアンインストールするとFlash Playerで動画やライブ配信コンテンツなどを見てる時に一定時間経つと音が出なくなる現象が起こります。

これはFlashだけなのでHTML5やSilverlightなどの動画コンテンツには影響しませんし、保存した動画を再生しても起こりません。

ブラウザを再起動すれば音が復活しますがしばらくするとまた途切れます。

Flashの設定やサウンドの設定を変更してもダメでした。


これはもう根本的に解決するにはサウンドカードを増設するしか方法が無いかもしれません。

あるいはFlashなんてそのうち無くなりそうなのでそれまで我慢するかWindows10にアップグレードするかですかね。



・デバイスマネージャーに2つの「不明なデバイス」の表示

一つは「WPD FileSyestem Volume Driver」に関するものですが、これはPCケースのSDカードスロットのドライブレターを削除したのが原因らしいです。

ドライブレターを設定したら直りました。

ドライブレターを整理する時、よくわからないドライブがあったんでドライブレターを「削除」したらどうなるんだろうとやってみたんですが、こんなところに結果が出るとは思いませんでしたw。

ドライブレターを削除したらOSが勝手に適当なドライブレターをつけると思っていたけど違ってました。

ただ「削除」を何に使うのか、使うとどうなるのかネットで探しても詳しい情報は見つからないんよね。


もう一つは「Microsoft ACPI-Compliant System」、これはちょっと悩みましたが「デバイスマネージャー」でドライバーをインストールすれば解消しました。

これはバッテリーの電源管理をするものらしいですがデスクトップPCに必要か?というかそもそもなんで外れたのかが不明です。

でもこの解決方法が正しかったのかどうかは実際のところわかりません。ネットで見つけた方法の一つをやってみただけなので。



ピクソからディアクティベーション処理が完了したとメールが来たのでZBrushのアクティベーションを行いました。

ディアクティベーションでマシンを指定する時、Surface Pro2にあった2つのアクティベーションを選択したんですが、メールが来た時点でサーフェースのZBrushはまだ使える状態でした。

ちょっとすっきりしないのでこれは自分でディアクティベーションすることにしましたが、そもそもこれをPCでアクティベーションする時にやっておけばよかったんじゃないか?と後で気付いたw。


さて起動して使おうかと思って気がついた事が。

前の環境でディアクティベーションとアンインストールを行う時に自分で作ったデータや環境設定等のファイルを待避するのをすっかり忘れていました。

一瞬あせったけど、幸いアンインストール時にはディフォルトでインストールしたファイル以外削除されないらしく自作のファイルはそのまま前のHDDに残っていました。

まあ実際にはほとんどインストールフォルダーにデータを保存することはなくファイルのショートカットから他のドライブに保存させているんで、万一削除されてても影響はそんに無いとは思いますが。

おかげでショートカットやUI等のカスタマイズもほぼすんなり移行できました。

ZBrushの起動時間はLightBoxが表示されるまでで6~7秒程度です。



一応必要なソフトのインストールとOS設定などが終わったので以前使っていたHDDのシステムパーティションを削除してPC本体に戻して取り付けました。

ちょっと困ったのはそれまでこのHDDをUSBに繋いで使っていたのでPCに取り付けたら起動時に「自動再生」ウィンドウを出すようになったことです。

これは「コントロールパネル」>「自動再生」で「すべての規定値をリセットする」>「保存」で解決しましたが、これが正解かどうかわかりません。


またPCのシャットダウンで毎回「更新プログラムをインストールしてからシャットダウン」が表示されるようになりました。

Windows Updateを調べてもインストールが必要な更新プログラムはありません。

これは下のサイトの「ベストアンサー」の解説が参考になりました。

http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q14121597154


あともう一つ

Asusからマザボ関連のアップデートなどを入手してアップデートを試みましたがインストーラがうまく起動しません。

コマンドプロンプトのウィンドウが表示されただけで全く反応無しです。

アップデータにはRead me等の説明が一切ないので対処の仕方がわかりませんでしたがサブフォルダーのインストーラーを起動したらインストールできました。

で、ここでのインストールの失敗が影響したのか起動時に「AsusSetup log.iniis lost」というエラーがいくつも出るようになりました。

これは下の解説が参考になりました。

http://michisugara.jp/archives/2013/asussetup_error.html



ハードの増設とかOSのインストールとか何度もやって来ましたが、今回ほど多くのトラブルに見舞われたことはありません。

10年分のトラブルを一度に経験した感じですw。まあおかげでいろいろ勉強にはなりましたが。

ここらあたりでシステムイメージをバックアップしておきますかね?。



コメント

コメントの投稿


管理者にだけ表示を許可する

トラックバック

トラックバック URL
http://momonchan574.blog65.fc2.com/tb.php/871-bb318c64
この記事にトラックバックする(FC2ブログユーザー)

FC2Ad

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。